USE-Together-2.2-is-out